about summary refs log tree commit diff
path: root/configurations/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configurations/default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/configurations/default.nix b/configurations/default.nix
index 088060b..c1712db 100644
--- a/configurations/default.nix
+++ b/configurations/default.nix
@@ -1,5 +1,5 @@
-{ inputs, ... }:
-with inputs.self.lib;
+{ inputs, lib, ... }:
+with lib;
 let
   mkConfiguration =
     name:
@@ -16,8 +16,7 @@ let
         ++ attrValues inputs.nix-topology.nixosModules
         ++ optional (configuration != null) (import configuration);
       specialArgs = {
-        inherit inputs this;
-        inherit (inputs.self) lib;
+        inherit inputs lib this;
       };
     });
 in

Consider giving Nix/NixOS a try! <3