about summary refs log tree commit diff
path: root/configurations/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configurations/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/configurations/default.nix b/configurations/default.nix
index 40c133f..684b4e4 100644
--- a/configurations/default.nix
+++ b/configurations/default.nix
@@ -18,6 +18,7 @@ with lib; let
     });
 in
   mapAttrs' mkConfiguration {
+    # A dummy configuration to test the "headless" profile.
     test-headless = {
       modules = with inputs; [
         "${nixpkgs}/nixos/modules/profiles/qemu-guest.nix"
@@ -31,6 +32,7 @@ in
       };
     };
 
+    # A dummy configuration to test the "headful" profile.
     test-headful = {
       modules = with inputs; [
         "${nixpkgs}/nixos/modules/profiles/qemu-guest.nix"
@@ -44,12 +46,22 @@ in
       };
     };
 
+    # Planned: a beefy tower desktop PC.
+    # eonwe.modules = with inputs; [
+    #   nixos-hardware.nixosModules.common-cpu-amd
+    #   nixos-hardware.nixosModules.common-gpu-amd
+    #   nixos-hardware.nixosModules.common-pc-ssd
+    #   nixpkgs.nixosModules.notDetected
+    # ];
+
+    # ThinkPad T480.
     melian.modules = with inputs; [
       nixos-hardware.nixosModules.common-pc-laptop-ssd
       nixos-hardware.nixosModules.lenovo-thinkpad-t480
       nixpkgs.nixosModules.notDetected
     ];
 
+    # VPS: Germany
     manwe.modules = with inputs; [
       "${nixpkgs}/nixos/modules/profiles/qemu-guest.nix"
       nixos-hardware.nixosModules.common-cpu-amd
@@ -57,6 +69,7 @@ in
       nixpkgs.nixosModules.notDetected
     ];
 
+    # VPS: Germany
     varda.modules = with inputs; [
       "${nixpkgs}/nixos/modules/profiles/qemu-guest.nix"
       nixos-hardware.nixosModules.common-cpu-amd
@@ -64,6 +77,7 @@ in
       nixpkgs.nixosModules.notDetected
     ];
 
+    # VPS: France
     yavanna.modules = with inputs; [
       "${nixpkgs}/nixos/modules/profiles/qemu-guest.nix"
       nixos-hardware.nixosModules.common-cpu-intel

Consider giving Nix/NixOS a try! <3