about summary refs log tree commit diff
path: root/configurations/eonwe/vidya.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configurations/eonwe/vidya.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/configurations/eonwe/vidya.nix b/configurations/eonwe/vidya.nix
new file mode 100644
index 0000000..d2b85f5
--- /dev/null
+++ b/configurations/eonwe/vidya.nix
@@ -0,0 +1,38 @@
+{ pkgs, ... }:
+{
+  nixfiles.modules = {
+    common.nix.allowedUnfreePackages = [
+      "dwarf-fortress"
+      "fallout-ce"
+      "fallout2-ce"
+    ];
+
+    games = {
+      lutris.enable = true;
+
+      steam.enable = true;
+      steam-run.quirks.blackIsleStudios = true;
+
+      minecraft.client.enable = true;
+    };
+  };
+
+  hm.home.packages = with pkgs; [
+    (crawl.override { tileMode = true; })
+    (dwarf-fortress-packages.dwarf-fortress-full.override {
+      dfVersion = "0.47.05";
+      theme = "cla";
+      enableIntro = false;
+      enableFPS = true;
+    })
+    fallout-ce
+    fallout2-ce
+    gzdoom
+    nethack
+    openmw
+    openttd
+    qzdl
+    vcmi
+    xonotic
+  ];
+}

Consider giving Nix/NixOS a try! <3