about summary refs log tree commit diff
path: root/configurations/manwe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configurations/manwe/default.nix41
1 files changed, 8 insertions, 33 deletions
diff --git a/configurations/manwe/default.nix b/configurations/manwe/default.nix
index 5531cb9..db08c3f 100644
--- a/configurations/manwe/default.nix
+++ b/configurations/manwe/default.nix
@@ -43,45 +43,20 @@ with lib; {
     vaultwarden.enable = true;
   };
 
-  networking = let
-    interface = "eth0";
-  in {
-    interfaces.${interface} = {
-      ipv4.addresses = [
-        {
-          inherit (this.ipv4) address;
-          prefixLength = 22;
-        }
-      ];
-
-      ipv6.addresses = [
-        {
-          inherit (this.ipv6) address;
-          prefixLength = 64;
-        }
-      ];
-    };
-
-    defaultGateway = {
-      inherit interface;
-      address = this.ipv4.gateway;
-    };
-
-    defaultGateway6 = {
-      inherit interface;
-      address = this.ipv6.gateway;
-    };
-
-    nat.externalInterface = interface;
-  };
-
   boot = {
     loader.grub = {
       enable = true;
       device = "/dev/sda";
     };
 
-    initrd.availableKernelModules = ["ata_piix" "uhci_hcd" "virtio_pci" "virtio_scsi" "sd_mod" "sr_mod"];
+    initrd.availableKernelModules = [
+      "ata_piix"
+      "sd_mod"
+      "sr_mod"
+      "uhci_hcd"
+      "virtio_pci"
+      "virtio_scsi"
+    ];
   };
 
   fileSystems = {

Consider giving Nix/NixOS a try! <3