summaryrefslogtreecommitdiff
path: root/configurations/yavanna/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/yavanna/default.nix')
-rw-r--r--configurations/yavanna/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/configurations/yavanna/default.nix b/configurations/yavanna/default.nix
new file mode 100644
index 0000000..2d52f53
--- /dev/null
+++ b/configurations/yavanna/default.nix
@@ -0,0 +1,32 @@
+_: {
+ nixfiles.modules = {
+ wireguard.client.enable = true;
+
+ syncthing.enable = true;
+
+ acme.enable = true;
+
+ rtorrent.enable = true;
+ lidarr.enable = true;
+ jackett.enable = true;
+ };
+
+ boot.loader.grub = {
+ enable = true;
+ device = "/dev/sda";
+ configurationLimit = 5;
+ };
+
+ fileSystems."/" = {
+ device = "/dev/sda2";
+ fsType = "ext4";
+ options = [ "noatime" ];
+ };
+
+ swapDevices = [ { device = "/dev/sda3"; } ];
+
+ zramSwap = {
+ enable = true;
+ memoryPercent = 25;
+ };
+}