about summary refs log tree commit diff
path: root/darwinConfigurations/mairon/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--darwinConfigurations/mairon/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/darwinConfigurations/mairon/default.nix b/darwinConfigurations/mairon/default.nix
new file mode 100644
index 0000000..d574a08
--- /dev/null
+++ b/darwinConfigurations/mairon/default.nix
@@ -0,0 +1,22 @@
+{
+  config,
+  lib,
+  this,
+  ...
+}:
+with lib; {
+  nixfiles.modules.vscode.enable = true;
+
+  # TODO Make this per-directory/per-remote.
+  hm.programs.git = {
+    userName = mkForce "Firstname Lastname";
+    userEmail = mkForce "username@work.com";
+    signing.key = mkForce "@PGP_KEY@";
+    extraConfig."url \"git@gitlab.services.work.com:\"".insteadOf = "work:";
+  };
+
+  networking = {
+    computerName = mkForce this.hostname;
+    hostName = mkForce null;
+  };
+}

Consider giving Nix/NixOS a try! <3