about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix15
1 files changed, 14 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index dd9473e..c76a436 100644
--- a/flake.nix
+++ b/flake.nix
@@ -74,6 +74,18 @@
       ref = "master";
     };
 
+    nixvim = {
+      type = "github";
+      owner = "nix-community";
+      repo = "nixvim";
+      ref = "main";
+      inputs = {
+        flake-utils.follows = "flake-utils";
+        nixpkgs.follows = "nixpkgs";
+        pre-commit-hooks.follows = "pre-commit-hooks";
+      };
+    };
+
     nix-vscode-extensions = {
       type = "github";
       owner = "nix-community";
@@ -271,7 +283,8 @@
         };
       in {
         packages = with lib;
-          (mapAttrs (_: c: c.config.system.build.toplevel)
+          pkgs
+          // (mapAttrs (_: c: c.config.system.build.toplevel)
             (builtins.removeAttrs self.nixosConfigurations ["iso-arm" "iso-x86"]))
           // (let
             buildIsoImage = name: self.nixosConfigurations.${name}.config.system.build.isoImage;

Consider giving Nix/NixOS a try! <3