about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix198
1 files changed, 50 insertions, 148 deletions
diff --git a/flake.nix b/flake.nix
index 04ce52b..f41d90f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,113 +1,60 @@
 {
-  description = "azahi's NixOS/nix-darwin/home-manager den";
+  description = "Hi!";
 
   # The `flake.lock` generation is not computable[1]. So far it's impossible to
   # add helper functions to manage inputs.
   #
   # [1]: https://github.com/NixOS/nix/issues/5373
   inputs = {
-    nixpkgs = {
-      # type = "path";
-      # path = "/home/azahi/src/nixpkgs";
-      type = "github";
-      owner = "NixOS";
-      repo = "nixpkgs";
-      ref = "nixpkgs-unstable";
-    };
-
-    # nixpkgs-local = {
-    #   type = "path";
-    #   path = "/home/azahi/src/nixpkgs";
-    # };
-
-    nixpkgs-master = {
-      type = "github";
-      owner = "NixOS";
-      repo = "nixpkgs";
-      ref = "master";
-    };
+    nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+    nixpkgs-master.url = "github:NixOS/nixpkgs/master";
+    nixpkgs-stable.url = "github:NixOS/nixpkgs/release-23.11";
 
-    nixpkgs-stable = {
-      type = "github";
-      owner = "NixOS";
-      repo = "nixpkgs";
-      ref = "release-23.11";
-    };
-
-    nixos-hardware = {
-      type = "github";
-      owner = "NixOS";
-      repo = "nixos-hardware";
-      ref = "master";
-    };
+    nixos-hardware.url = "github:NixOS/nixos-hardware";
 
     darwin = {
-      type = "github";
-      owner = "LnL7";
-      repo = "nix-darwin";
-      ref = "master";
+      url = "github:LnL7/nix-darwin";
       inputs.nixpkgs.follows = "nixpkgs";
     };
 
     home-manager = {
-      # type = "path";
-      # path = "/home/azahi/src/home-manager";
-      type = "github";
-      owner = "nix-community";
-      repo = "home-manager";
-      ref = "master";
+      url = "github:nix-community/home-manager";
       inputs.nixpkgs.follows = "nixpkgs";
     };
 
-    impermanence = {
-      type = "github";
-      owner = "nix-community";
-      repo = "impermanence";
-      ref = "master";
-    };
+    impermanence.url = "github:nix-community/impermanence";
 
-    nixvim = {
-      type = "github";
-      owner = "nix-community";
-      repo = "nixvim";
-      ref = "main";
+    agenix = {
+      url = "github:ryantm/agenix";
       inputs = {
-        flake-utils.follows = "flake-utils";
+        darwin.follows = "darwin";
+        home-manager.follows = "home-manager";
         nixpkgs.follows = "nixpkgs";
-        pre-commit-hooks.follows = "pre-commit-hooks";
+        systems.follows = "systems";
       };
     };
 
-    nix-vscode-extensions = {
-      type = "github";
-      owner = "nix-community";
-      repo = "nix-vscode-extensions";
-      ref = "master";
+    dns = {
+      url = "github:kirelagin/dns.nix";
       inputs = {
-        flake-compat.follows = "flake-compat";
         flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
       };
     };
 
-    arkenfox-nixos = {
-      type = "github";
-      owner = "dwarfmaster";
-      repo = "arkenfox-nixos";
-      ref = "main";
+    mailserver = {
+      url = "gitlab:simple-nixos-mailserver/nixos-mailserver";
       inputs = {
         flake-compat.follows = "flake-compat";
-        flake-utils.follows = "flake-utils";
+        nixpkgs-22_11.follows = "nixpkgs-stable";
+        nixpkgs-23_05.follows = "nixpkgs-stable";
         nixpkgs.follows = "nixpkgs";
-        pre-commit.follows = "pre-commit-hooks";
+        utils.follows = "flake-utils";
       };
     };
 
-    nix-minecraft = {
-      type = "github";
-      owner = "Infinidoge";
-      repo = "nix-minecraft";
-      ref = "master";
+    alertmanager-ntfy = {
+      url = "github:pinpox/alertmanager-ntfy";
       inputs = {
         flake-compat.follows = "flake-compat";
         flake-utils.follows = "flake-utils";
@@ -115,86 +62,35 @@
       };
     };
 
-    dns-nix = {
-      type = "github";
-      owner = "kirelagin";
-      repo = "dns.nix";
-      ref = "master";
-      inputs = {
-        flake-utils.follows = "flake-utils";
-        nixpkgs.follows = "nixpkgs";
-      };
-    };
-
-    simple-nixos-mailserver = {
-      type = "gitlab";
-      owner = "simple-nixos-mailserver";
-      repo = "nixos-mailserver";
-      ref = "master";
+    vscode-extensions = {
+      url = "github:nix-community/nix-vscode-extensions";
       inputs = {
         flake-compat.follows = "flake-compat";
-        nixpkgs-22_11.follows = "nixpkgs-stable";
-        nixpkgs-23_05.follows = "nixpkgs-stable";
+        flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
-        utils.follows = "flake-utils";
       };
     };
 
-    alertmanager-ntfy = {
-      type = "github";
-      owner = "pinpox";
-      repo = "alertmanager-ntfy";
-      ref = "main";
+    arkenfox = {
+      url = "github:dwarfmaster/arkenfox-nixos";
       inputs = {
         flake-compat.follows = "flake-compat";
         flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
+        pre-commit.follows = "pre-commit";
       };
     };
 
-    flake-utils = {
-      type = "github";
-      owner = "numtide";
-      repo = "flake-utils";
-      ref = "main";
-    };
-
-    flake-registry = {
-      type = "github";
-      owner = "NixOS";
-      repo = "flake-registry";
-      ref = "master";
-      flake = false;
-    };
-
-    agenix = {
-      type = "github";
-      owner = "ryantm";
-      repo = "agenix";
-      ref = "main";
-      inputs = {
-        darwin.follows = "darwin";
-        home-manager.follows = "home-manager";
-        nixpkgs.follows = "nixpkgs";
-      };
-    };
-
-    pre-commit-hooks = {
-      type = "github";
-      owner = "cachix";
-      repo = "pre-commit-hooks.nix";
-      ref = "master";
+    minecraft = {
+      url = "github:Infinidoge/nix-minecraft";
       inputs = {
         flake-compat.follows = "flake-compat";
         flake-utils.follows = "flake-utils";
-        nixpkgs-stable.follows = "nixpkgs-stable";
         nixpkgs.follows = "nixpkgs";
       };
     };
 
     xmonad-ng = {
-      # type = "path";
-      # path = "/home/azahi/src/xmonad-ng";
       url = "git+https://git.azahi.cc/xmonad-ng?ref=master";
       inputs = {
         flake-utils.follows = "flake-utils";
@@ -208,27 +104,33 @@
     };
 
     nmap-vulners = {
-      type = "github";
-      owner = "vulnersCom";
-      repo = "nmap-vulners";
-      ref = "master";
+      url = "github:vulnersCom/nmap-vulners/master";
       flake = false;
     };
-
     nmap-vulscan = {
-      type = "github";
-      owner = "scipag";
-      repo = "vulscan";
-      ref = "master";
+      url = "github:scipag/vulscan/master";
       flake = false;
     };
 
-    flake-compat = {
-      type = "github";
-      owner = "edolstra";
-      repo = "flake-compat";
-      ref = "master";
+    pre-commit = {
+      url = "github:cachix/pre-commit-hooks.nix/master";
+      inputs = {
+        flake-compat.follows = "flake-compat";
+        flake-utils.follows = "flake-utils";
+        nixpkgs.follows = "nixpkgs";
+      };
+    };
+
+    systems.url = "github:nix-systems/default";
+    flake-utils = {
+      url = "github:numtide/flake-utils";
+      inputs.systems.follows = "systems";
+    };
+    flake-registry = {
+      url = "github:NixOS/flake-registry";
+      flake = false;
     };
+    flake-compat.url = "github:edolstra/flake-compat/master";
   };
 
   outputs = inputs:

Consider giving Nix/NixOS a try! <3