about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix92
1 files changed, 46 insertions, 46 deletions
diff --git a/flake.nix b/flake.nix
index adb7416..dc194f5 100644
--- a/flake.nix
+++ b/flake.nix
@@ -33,16 +33,12 @@
       inputs = {
         home-manager.follows = "home-manager";
         nixpkgs.follows = "nixpkgs";
-        systems.follows = "systems";
       };
     };
 
     dns = {
       url = "github:kirelagin/dns.nix";
-      inputs = {
-        flake-utils.follows = "flake-utils";
-        nixpkgs.follows = "nixpkgs";
-      };
+      inputs.nixpkgs.follows = "nixpkgs";
     };
 
     mailserver = {
@@ -50,7 +46,6 @@
       inputs = {
         flake-compat.follows = "flake-compat";
         nixpkgs.follows = "nixpkgs";
-        utils.follows = "flake-utils";
       };
     };
 
@@ -58,7 +53,6 @@
       url = "github:pinpox/alertmanager-ntfy";
       inputs = {
         flake-compat.follows = "flake-compat";
-        flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
       };
     };
@@ -67,7 +61,6 @@
       url = "github:nix-community/nix-vscode-extensions";
       inputs = {
         flake-compat.follows = "flake-compat";
-        flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
       };
     };
@@ -76,9 +69,8 @@
       url = "github:dwarfmaster/arkenfox-nixos";
       inputs = {
         flake-compat.follows = "flake-compat";
-        flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
-        pre-commit.follows = "pre-commit";
+        pre-commit.follows = "git-hooks";
       };
     };
 
@@ -86,7 +78,6 @@
       url = "github:Infinidoge/nix-minecraft";
       inputs = {
         flake-compat.follows = "flake-compat";
-        flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
       };
     };
@@ -96,87 +87,96 @@
       inputs.nixpkgs.follows = "nixpkgs";
     };
 
-    xmonad-ng = {
-      url = "git+https://git.azahi.cc/xmonad-ng?ref=master";
+    nix-topology = {
+      url = "github:oddlama/nix-topology";
       inputs = {
-        flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
+        pre-commit-hooks.follows = "git-hooks";
       };
     };
 
+    xmonad-ng = {
+      url = "git+https://git.azahi.cc/xmonad-ng?ref=master";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
+
     azahi-cc = {
       url = "git+https://git.azahi.cc/azahi-cc?ref=master";
       flake = false;
     };
 
     nmap-vulners = {
-      url = "github:vulnersCom/nmap-vulners/master";
+      url = "github:vulnersCom/nmap-vulners";
       flake = false;
     };
     nmap-vulscan = {
-      url = "github:scipag/vulscan/master";
+      url = "github:scipag/vulscan";
       flake = false;
     };
 
-    pre-commit = {
-      url = "github:cachix/pre-commit-hooks.nix/master";
+    git-hooks = {
+      url = "github:cachix/git-hooks.nix";
       inputs = {
         flake-compat.follows = "flake-compat";
-        flake-utils.follows = "flake-utils";
         nixpkgs.follows = "nixpkgs";
         nixpkgs-stable.follows = "nixpkgs-stable";
       };
     };
 
-    systems.url = "github:nix-systems/default";
-    flake-utils = {
-      url = "github:numtide/flake-utils";
-      inputs.systems.follows = "systems";
-    };
     flake-registry = {
       url = "github:NixOS/flake-registry";
       flake = false;
     };
-    flake-compat.url = "github:edolstra/flake-compat/master";
+    flake-compat.url = "github:edolstra/flake-compat";
   };
 
   outputs =
-    inputs:
-    with inputs;
-    flake-utils.lib.eachDefaultSystem (system: {
-      apps.default = {
-        type = "app";
-        program = "${self.packages.${system}.default}/bin/nixfiles";
+    inputs@{ self, nixpkgs, ... }:
+    let
+      system = "x86_64-linux";
+
+      pkgs = import nixpkgs {
+        inherit system;
+        overlays = [
+          self.overlays.default
+          inputs.nix-topology.overlays.default
+        ];
       };
+    in
+    {
+      lib = nixpkgs.lib.extend (import ./lib);
+
+      legacyPackages.${system} = pkgs;
+
+      packages.${system} = {
+        default = self.packages.${system}.nixfiles;
+        inherit (self.legacyPackages.${system}) nixfiles;
 
-      packages = {
-        default = self.legacyPackages.${system}.nixfiles;
         iso = self.nixosConfigurations.iso.config.system.build.isoImage;
       };
 
-      legacyPackages = import nixpkgs {
-        inherit system;
-        overlays = [ self.overlays.default ];
+      apps.${system}.default = {
+        type = "app";
+        program = self.lib.getExe self.packages.${system}.nixfiles;
       };
 
-      devShells.default =
-        with self.legacyPackages.${system};
+      overlays = import ./overlays.nix;
+
+      devShells.${system}.default =
+        with pkgs;
         mkShell {
           inherit (self.checks.${system}.preCommit) shellHook;
           packages = [ go-task ];
         };
 
-      formatter = self.legacyPackages.${system}.nixfmt;
+      nixosModules = import ./modules self.lib;
 
-      checks = import ./checks.nix { inherit inputs system; };
-    })
-    // {
-      lib = nixpkgs.lib.extend (import ./lib);
+      nixosConfigurations = import ./configurations inputs;
 
-      nixosModules.nixfiles = import ./modules;
+      checks.${system} = import ./checks.nix inputs system pkgs;
 
-      nixosConfigurations = import ./nixosConfigurations inputs;
+      formatter.${system} = pkgs.nixfmt;
 
-      overlays.default = final: prev: import ./overlay.nix final prev;
+      topology = import ./topology.nix inputs self pkgs;
     };
 }

Consider giving Nix/NixOS a try! <3