about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index c082411..62f958d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -155,7 +155,7 @@
   outputs =
     inputs@{ self, nixpkgs, ... }:
     let
-      lib = nixpkgs.lib.extend (import ./lib);
+      lib = nixpkgs.lib.extend (lib: _: (import ./lib { inherit inputs lib system; }));
 
       system = "x86_64-linux";
 
@@ -167,12 +167,13 @@
         ];
       };
     in
+    with lib;
     {
       inherit lib;
 
       apps.${system}.default = {
         type = "app";
-        program = self.lib.getExe self.packages.${system}.nixfiles;
+        program = getExe self.packages.${system}.nixfiles;
       };
 
       packages.${system} = {
@@ -188,7 +189,7 @@
 
       legacyPackages.${system} = pkgs;
 
-      overlays = import ./overlays.nix lib;
+      overlays = import ./overlays.nix { inherit lib inputs; };
 
       devShells.${system}.default =
         with pkgs;
@@ -201,10 +202,7 @@
 
       checks.${system} = import ./checks.nix { inherit inputs pkgs system; };
 
-      nixosModules.default =
-        _: with lib; {
-          imports = attrValues (modulesIn ./modules);
-        };
+      nixosModules.default = _: { imports = attrValues (modulesIn ./modules); };
 
       nixosConfigurations = import ./configurations { inherit inputs lib pkgs; };
 

Consider giving Nix/NixOS a try! <3