about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 8d7981a..dce2869 100644
--- a/flake.nix
+++ b/flake.nix
@@ -222,7 +222,7 @@
     with inputs; let
       lib = nixpkgs.lib.extend (import ./lib);
     in
-      flake-utils.lib.eachSystem ["x86_64-linux"]
+      flake-utils.lib.eachSystem ["x86_64-linux" "aarch64-linux"]
       (system: let
         pkgs = import nixpkgs {
           inherit system;
@@ -240,6 +240,7 @@
           inherit (self.checks.${system}.preCommit) shellHook;
         };
 
+        # Very opinionated but works fast and doesn't get in a way like nixfmt.
         formatter = pkgs.alejandra;
 
         checks.preCommit = pre-commit-hooks.lib.${system}.run {
@@ -254,6 +255,7 @@
             shellcheck.enable = true;
             shfmt.enable = true;
             statix.enable = true;
+            # nix-linter.enable = true; # Takes annoyingly long time to parse stuff.
           };
         };
       })
@@ -265,6 +267,7 @@
         nixosConfigurations =
           import ./configurations {inherit inputs lib;};
 
+        # TODO Make it so self.pckages also can use this.
         overlays.default = final: _: {
           UltimMC = final.libsForQt5.callPackage ./packages/ultimmc.nix {};
           bruh = final.callPackage ./packages/bruh.nix {};

Consider giving Nix/NixOS a try! <3