about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix21
1 files changed, 12 insertions, 9 deletions
diff --git a/flake.nix b/flake.nix
index 855913d..e5bd0b9 100644
--- a/flake.nix
+++ b/flake.nix
@@ -88,14 +88,6 @@
       };
     };
 
-    arkenfox-nixos = {
-      type = "github";
-      owner = "dwarfmaster";
-      repo = "arkenfox-nixos";
-      ref = "main";
-      inputs.nixpkgs.follows = "nixpkgs";
-    };
-
     # Waiting for patches[1]. Currently, the new profile feature breaks
     # everything and I don't want to spend 12 hours debugging this shit.
     #
@@ -115,6 +107,14 @@
     #   };
     # };
 
+    arkenfox-nixos = {
+      type = "github";
+      owner = "dwarfmaster";
+      repo = "arkenfox-nixos";
+      ref = "main";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
+
     nix-minecraft = {
       type = "github";
       owner = "Infinidoge";
@@ -191,7 +191,10 @@
       owner = "ryantm";
       repo = "agenix";
       ref = "main";
-      inputs.nixpkgs.follows = "nixpkgs";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        darwin.follows = "darwin";
+      };
     };
 
     pre-commit-hooks = {

Consider giving Nix/NixOS a try! <3