about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix30
1 files changed, 19 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index a1fe2f5..ae5d91a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -145,17 +145,17 @@
     #     nixpkgs.follows = "nixpkgs";
     #   };
     # };
-    # alertmanager-gotify = {
-    #   type = "github";
-    #   owner = "pinpox";
-    #   repo = "alertmanager-ntfy";
-    #   ref = "main";
-    #   inputs = {
-    #     flake-compat.follows = "flake-compat";
-    #     flake-utils.follows = "flake-utils";
-    #     nixpkgs.follows = "nixpkgs";
-    #   };
-    # };
+    alertmanager-ntfy = {
+      type = "github";
+      owner = "pinpox";
+      repo = "alertmanager-ntfy";
+      ref = "main";
+      inputs = {
+        flake-compat.follows = "flake-compat";
+        flake-utils.follows = "flake-utils";
+        nixpkgs.follows = "nixpkgs";
+      };
+    };
 
     flake-utils = {
       type = "github";
@@ -291,6 +291,14 @@
               enable = true;
               types = ["text"];
             };
+            yamllint.enable = true;
+            promtool = {
+              enable = true;
+              name = "promtool";
+              description = "Check Prometheus rules.";
+              entry = "${pkgs.prometheus.cli}/bin/promtool check rules";
+              files = "(?x)^(modules/nixos/monitoring/rules/.*\.yaml)$";
+            };
           };
           settings.deadnix.edit = true;
         };

Consider giving Nix/NixOS a try! <3