summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index d042cff..cfd62b6 100644
--- a/flake.nix
+++ b/flake.nix
@@ -33,6 +33,14 @@
# path = "/home/azahi/src/nixpkgs";
# };
+ # FIXME https://github.com/NixOS/nixpkgs/pull/187026
+ nixpkgs-endlessh-go = {
+ type = "github";
+ owner = "azahi";
+ repo = "nixpkgs";
+ ref = "endlessh-go";
+ };
+
nixos-hardware = {
type = "github";
owner = "NixOS";
@@ -222,9 +230,7 @@
overlays = [self.overlays.default];
};
in {
- packages.default = pkgs.nixfiles.override {
- nixfilesSrc = ".";
- };
+ packages.default = pkgs.nixfiles;
apps.${system}.default = {
type = "app";
@@ -260,7 +266,6 @@
nixosConfigurations =
import ./configurations {inherit inputs lib;};
- # TODO Generalise this.
overlays.default = final: _: {
UltimMC = final.libsForQt5.callPackage ./packages/ultimmc.nix {};
bruh = final.callPackage ./packages/bruh.nix {};