summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix37
1 files changed, 20 insertions, 17 deletions
diff --git a/flake.nix b/flake.nix
index 5cdf643..a4a9c4c 100644
--- a/flake.nix
+++ b/flake.nix
@@ -92,25 +92,28 @@
type = "github";
owner = "dwarfmaster";
repo = "arkenfox-nixos";
- # FIXME https://github.com/dwarfmaster/arkenfox-nixos/issues/20
- ref = "5985ba832c841af5805c89d64f78bfae2a0f331f";
+ ref = "main";
inputs.nixpkgs.follows = "nixpkgs";
};
- nix-doom-emacs = {
- # type = "path";
- # path = "/home/azahi/src/nix-doom-emacs";
- type = "github";
- owner = "nix-community";
- repo = "nix-doom-emacs";
- ref = "master";
- inputs = {
- flake-compat.follows = "flake-compat";
- emacs-overlay.follows = "emacs-overlay";
- flake-utils.follows = "flake-utils";
- nixpkgs.follows = "nixpkgs";
- };
- };
+ # Waiting for patches[1]. Currently, the new profile feature breaks
+ # everything and I don't want to spend 12 hours debugging this shit.
+ #
+ # [1]: https://github.com/nix-community/nix-doom-emacs/pull/316
+ # nix-doom-emacs = {
+ # # type = "path";
+ # # path = "/home/azahi/src/nix-doom-emacs";
+ # type = "github";
+ # owner = "nix-community";
+ # repo = "nix-doom-emacs";
+ # ref = "master";
+ # inputs = {
+ # flake-compat.follows = "flake-compat";
+ # emacs-overlay.follows = "emacs-overlay";
+ # flake-utils.follows = "flake-utils";
+ # nixpkgs.follows = "nixpkgs";
+ # };
+ # };
nix-minecraft = {
type = "github";
@@ -305,7 +308,7 @@
// {
inherit lib;
- modules.nixfiles = import ./modules/nixfiles;
+ modules.nixfiles = import ./modules/common;
nixosModules.nixfiles = import ./modules/nixos;
nixosConfigurations =