summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix42
1 files changed, 18 insertions, 24 deletions
diff --git a/flake.nix b/flake.nix
index ba845a4..4f3eacb 100644
--- a/flake.nix
+++ b/flake.nix
@@ -66,6 +66,13 @@
};
};
+ impermanence = {
+ type = "github";
+ owner = "nix-community";
+ repo = "impermanence";
+ ref = "master";
+ };
+
emacs-overlay = {
type = "github";
owner = "nix-community";
@@ -98,30 +105,16 @@
};
};
- # nil = {
- # type = "github";
- # owner = "oxalica";
- # repo = "nil";
- # ref = "main";
- # inputs = {
- # flake-utils.follows = "flake-utils";
- # nixpkgs.follows = "nixpkgs";
- # };
- # };
-
- # NOTE This[1] is annoying.
- #
- # [1]: https://github.com/NixOS/nix/pull/6983#issuecomment-1234335417
- # nix-minecraft-servers = {
- # type = "github";
- # owner = "jyooru";
- # repo = "nix-minecraft-servers";
- # ref = "main";
- # inputs = {
- # nixpkgs.follows = "nixpkgs";
- # utils.inputs.flake-utils.follows = "flake-utils";
- # };
- # };
+ nix-minecraft = {
+ type = "github";
+ owner = "Infinidoge";
+ repo = "nix-minecraft";
+ ref = "master";
+ inputs = {
+ nixpkgs.follows = "nixpkgs";
+ flake-utils.follows = "flake-utils";
+ };
+ };
pollymc = {
type = "github";
@@ -151,6 +144,7 @@
repo = "nixos-mailserver";
ref = "master";
inputs = {
+ flake-compat.follows = "flake-compat";
nixpkgs-22_11.follows = "nixpkgs-stable";
nixpkgs.follows = "nixpkgs";
utils.follows = "flake-utils";