about summary refs log tree commit diff
path: root/lib/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--lib/default.nix19
1 files changed, 6 insertions, 13 deletions
diff --git a/lib/default.nix b/lib/default.nix
index cd4b601..a6a25c9 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -33,20 +33,13 @@ lib: _: with lib; rec {
       builtins.readDir
       (mapAttrsToList (
         name: type:
+        let
+          modulePath = dir + "/${name}";
+        in
         if type == "regular" && hasSuffix ".nix" name && name != "default.nix" then
-          [
-            {
-              name = removeSuffix ".nix" name;
-              value = dir + "/${name}";
-            }
-          ]
-        else if type == "directory" && pathExists (dir + "/${name}/default.nix") then
-          [
-            {
-              inherit name;
-              value = dir + "/${name}";
-            }
-          ]
+          [ (nameValuePair (removeSuffix ".nix" name) modulePath) ]
+        else if type == "directory" && pathExists (modulePath + "/default.nix") then
+          [ (nameValuePair name modulePath) ]
         else
           [ ]
       ))

Consider giving Nix/NixOS a try! <3