about summary refs log tree commit diff
path: root/modules/clickhouse.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/clickhouse.nix16
1 files changed, 15 insertions, 1 deletions
diff --git a/modules/clickhouse.nix b/modules/clickhouse.nix
index 12dc7fa..6bb53bb 100644
--- a/modules/clickhouse.nix
+++ b/modules/clickhouse.nix
@@ -1,4 +1,10 @@
-{ config, lib, ... }:
+{
+  config,
+  inputs,
+  lib,
+  this,
+  ...
+}:
 with lib;
 let
   cfg = config.nixfiles.modules.clickhouse;
@@ -12,5 +18,13 @@ in
     services.clickhouse = {
       enable = true;
     };
+
+    topology = {
+      nodes.${this.hostname}.services.clickhouse = {
+        name = "ClickHouse";
+        icon = "${inputs.homelab-svg-assets}/assets/postgresql.svg";
+        details.listen.text = "127.0.0.1:8123";
+      };
+    };
   };
 }

Consider giving Nix/NixOS a try! <3