about summary refs log tree commit diff
path: root/modules/clickhouse.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/clickhouse.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/modules/clickhouse.nix b/modules/clickhouse.nix
index 6bb53bb..f08678d 100644
--- a/modules/clickhouse.nix
+++ b/modules/clickhouse.nix
@@ -5,19 +5,16 @@
   this,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.clickhouse;
 in
 {
   options.nixfiles.modules.clickhouse = {
-    enable = mkEnableOption "Clickhouse";
+    enable = lib.mkEnableOption "Clickhouse";
   };
 
-  config = mkIf cfg.enable {
-    services.clickhouse = {
-      enable = true;
-    };
+  config = lib.mkIf cfg.enable {
+    services.clickhouse.enable = true;
 
     topology = {
       nodes.${this.hostname}.services.clickhouse = {

Consider giving Nix/NixOS a try! <3