about summary refs log tree commit diff
path: root/modules/common/alacritty.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/common/alacritty.nix72
1 files changed, 46 insertions, 26 deletions
diff --git a/modules/common/alacritty.nix b/modules/common/alacritty.nix
index 86d65eb..be3af21 100644
--- a/modules/common/alacritty.nix
+++ b/modules/common/alacritty.nix
@@ -19,7 +19,8 @@ in {
             y = size;
           };
           dynamic_padding = false;
-          decorations = "full";
+          decorations = "Full";
+          startup_mode = "Maximized";
         };
         font = with config.fontScheme.monospaceFont; {
           normal = {
@@ -41,7 +42,11 @@ in {
           inherit size;
         };
         colors = with config.colourScheme; {
-          primary = {inherit background foreground;};
+          primary = {
+            inherit background foreground;
+            dim_foreground = "None";
+            bright_foreground = "None";
+          };
           cursor = {
             text = "CellBackground";
             cursor = "CellForeground";
@@ -59,10 +64,6 @@ in {
               foreground = red;
               background = black;
             };
-            footer_bar = {
-              foreground = black;
-              background = white;
-            };
           };
           hints = {
             start = {
@@ -73,33 +74,52 @@ in {
               foreground = yellow;
               background = black;
             };
-            selection = {
-              text = "CellBackground";
-              background = "CellForeground";
-            };
-            normal = {
-              inherit black red green yellow blue magenta cyan white;
-            };
-            bright = {
-              inherit
-                brightBlack
-                brightRed
-                brightGreen
-                brightYellow
-                brightBlue
-                brightMagenta
-                brightCyan
-                brightWhite
-                ;
-            };
+          };
+          line_indicator = {
+            foreground = "None";
+            background = "None";
+          };
+          footer_bar = {
+            foreground = black;
+            background = white;
+          };
+          selection = {
+            text = "CellBackground";
+            background = "CellForeground";
+          };
+          normal = {
+            inherit
+              black
+              red
+              green
+              yellow
+              blue
+              magenta
+              cyan
+              white
+              ;
+          };
+          bright = {
+            black = brightBlack;
+            red = brightRed;
+            green = brightGreen;
+            yellow = brightYellow;
+            blue = brightBlue;
+            magenta = brightMagenta;
+            cyan = brightCyan;
+            white = brightWhite;
           };
         };
+        selection.save_to_clipboard = true;
         cursor = {
           style = {
             shape = "Block";
+            blinking = "On";
+          };
+          vi_mode_style = {
+            shape = "Block";
             blinking = "Off";
           };
-          vi_mode_style = "Block";
         };
       };
     };

Consider giving Nix/NixOS a try! <3