about summary refs log tree commit diff
path: root/modules/common/ark.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/ark.nix')
-rw-r--r--modules/common/ark.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/modules/common/ark.nix b/modules/common/ark.nix
index 1e43ef8..ba3056b 100644
--- a/modules/common/ark.nix
+++ b/modules/common/ark.nix
@@ -4,14 +4,13 @@
   lib,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.ark;
 in
 {
   imports = [
     inputs.impermanence.nixosModules.impermanence
-    (mkAliasOptionModule [ "ark" ] [
+    (lib.mkAliasOptionModule [ "ark" ] [
       "nixfiles"
       "modules"
       "ark"
@@ -20,16 +19,16 @@ in
 
   options.nixfiles.modules.ark =
     let
-      mkListOfAnythingOption = mkOption {
-        type = with types; listOf anything; # Assumed to be matching with the upstream type.
+      mkListOfAnythingOption = lib.mkOption {
+        type = with lib.types; listOf anything; # Assumed to be matching with the upstream type.
         default = [ ];
       };
     in
     {
-      enable = mkEnableOption "persistent storage support via impermanence";
+      enable = lib.mkEnableOption "persistent storage support via impermanence";
 
-      path = mkOption {
-        type = types.str;
+      path = lib.mkOption {
+        type = lib.types.str;
         default = "/ark";
       };
 
@@ -41,7 +40,7 @@ in
       # };
     };
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     environment.persistence.${cfg.path} = {
       hideMounts = true;
       enableDebugging = false;

Consider giving Nix/NixOS a try! <3