about summary refs log tree commit diff
path: root/modules/common/direnv.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/direnv.nix')
-rw-r--r--modules/common/direnv.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/common/direnv.nix b/modules/common/direnv.nix
new file mode 100644
index 0000000..b235cee
--- /dev/null
+++ b/modules/common/direnv.nix
@@ -0,0 +1,22 @@
+{
+  config,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.direnv;
+in {
+  options.nixfiles.modules.direnv.enable =
+    mkEnableOption "direnv";
+
+  config = mkIf cfg.enable {
+    hm = {
+      programs.direnv = {
+        enable = true;
+        nix-direnv.enable = true;
+      };
+
+      home.sessionVariables.DIRENV_LOG_FORMAT = "";
+    };
+  };
+}

Consider giving Nix/NixOS a try! <3