about summary refs log tree commit diff
path: root/modules/common/emacs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/common/emacs/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/modules/common/emacs/default.nix b/modules/common/emacs/default.nix
index 4d17e92..6c5ee1e 100644
--- a/modules/common/emacs/default.nix
+++ b/modules/common/emacs/default.nix
@@ -19,7 +19,6 @@ in {
     };
 
     nixfiles.modules = {
-      fonts.enable = true;
       git.client.enable = true;
       gnupg.enable = true;
       password-store.enable = true;
@@ -28,6 +27,8 @@ in {
     };
 
     hm = {
+      stylix.targets.emacs.enable = false;
+
       xdg.configFile = mapAttrs (_: value:
         value
         // {
@@ -171,10 +172,9 @@ in {
 
                 (appendq! auth-sources '(("${config.secrets.authinfo.path}")))
 
-                ;; The font must be set to n+2, otherwise it looks too small.
                 (setq doom-font (font-spec
-                                  :family "${config.fontScheme.monospaceFont.family}"
-                                  :size ${toString (config.fontScheme.monospaceFont.size + 2)})
+                                  :family "${config.stylix.fonts.monospace.name}"
+                                  :size 16)
                       doom-unicode-font doom-font)
 
                 ;; :input japanese

Consider giving Nix/NixOS a try! <3