summaryrefslogtreecommitdiff
path: root/modules/common/emacs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/emacs/default.nix')
-rw-r--r--modules/common/emacs/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/modules/common/emacs/default.nix b/modules/common/emacs/default.nix
index 6d1b549..7cd06e0 100644
--- a/modules/common/emacs/default.nix
+++ b/modules/common/emacs/default.nix
@@ -64,7 +64,6 @@ in {
extraBins = with pkgs;
[
(aspellWithDicts (p: with p; [en ru])) # :checkers (spell +aspell)
- # wordnet # :tools (lookup +dictionary +offline)
asmfmt # :editor format
cargo # :lang rust
clang-tools # :lang (cc +lsp) :editor format
@@ -114,6 +113,7 @@ in {
pandoc # :lang org markdown latex
pinentry-emacs # doom!
pipenv # :lang python
+ poetry # :lang python
pre-commit # :tools magit
python3 # :lang python
python3Packages.black # :lang python :editor format
@@ -133,6 +133,7 @@ in {
texlab # lang (tex +lsp)
texlive.combined.scheme-full # :lang org tex
unzip # :tools debugger
+ wordnet # :tools (lookup +dictionary +offline)
yaml-language-server # :lang (yaml +lsp)
zig # :lang zig :editor format
zls # :lang (zig +lsp)