about summary refs log tree commit diff
path: root/modules/common/git.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/common/git.nix16
1 files changed, 5 insertions, 11 deletions
diff --git a/modules/common/git.nix b/modules/common/git.nix
index aa157ed..fbd7ec7 100644
--- a/modules/common/git.nix
+++ b/modules/common/git.nix
@@ -31,6 +31,11 @@ in {
       };
     };
 
+    nixfiles.modules.common.shell.aliases = {
+      gl = "glab";
+      ht = "hut";
+    };
+
     hm = {
       home.packages = with pkgs; [
         git-extras
@@ -149,17 +154,6 @@ in {
           enable = true;
           settings.git_protocol = "ssh";
         };
-
-        bash = {
-          shellAliases = {
-            gl = "glab";
-            ht = "hut";
-          };
-          initExtra = mkAfter ''
-            _complete_alias gl __start_glab glab
-            _complete_alias ht __start_hut hut
-          '';
-        };
       };
     };
   };

Consider giving Nix/NixOS a try! <3