about summary refs log tree commit diff
path: root/modules/common/git.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/common/git.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/modules/common/git.nix b/modules/common/git.nix
index fbd7ec7..45a0347 100644
--- a/modules/common/git.nix
+++ b/modules/common/git.nix
@@ -68,7 +68,7 @@ in {
               core.whitespace = "trailing-space";
               init.defaultBranch = "master";
               status.submoduleSummary = true;
-              commit.verbose = 1;
+              commit.verbose = true;
               push.autoSetupRemote = true;
               pull.rebase = true;
               rebase = {
@@ -93,19 +93,22 @@ in {
               gitlab.user = my.username;
             }
             // mapAttrs'
-            (n: v: nameValuePair ''url "git@${v}:"'' {insteadOf = "${n}:";}) {
-              "alpine" = "gitlab.alpinelinux.org";
+            (name: value: nameValuePair ''url "git@${value}:"'' {insteadOf = "${name}:";}) {
               "bitbucket" = "bitbucket.com";
               "codeberg" = "codeberg.org";
-              "freedesktop" = "gitlab.freedesktop.org";
               "github" = "github.com";
               "gitlab" = "gitlab.com";
+              "sourcehut" = "git.sr.ht";
+            }
+            // mapAttrs'
+            (name: values: nameValuePair ''url "https://${values}/"'' {insteadOf = "${name}:";}) {
+              "alpine" = "gitlab.alpinelinux.org";
+              "freedesktop" = "gitlab.freedesktop.org";
               "gnome" = "gitlab.gnome.org";
               "haskell" = "gitlab.haskell.org";
               "kde" = "invent.kde.org";
               "notabug" = "notabug.org";
               "opencode" = "opencode.net";
-              "sourcehut" = "git.sr.ht";
               "torproject" = "gitlab.torproject.org";
               "videolan" = "code.videolan.org";
             };

Consider giving Nix/NixOS a try! <3