summaryrefslogtreecommitdiff
path: root/modules/common/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/git.nix')
-rw-r--r--modules/common/git.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/modules/common/git.nix b/modules/common/git.nix
index 0bd7720..2e5c834 100644
--- a/modules/common/git.nix
+++ b/modules/common/git.nix
@@ -13,23 +13,20 @@ in {
mkEnableOption "Git client";
config = mkIf cfg.client.enable {
- secrets = let
- # HACK MacOS doesn't support XDG specifications.
- configHome = "${config.my.home}/.config";
- in {
+ secrets = {
glab-cli-config = {
file = "${inputs.self}/secrets/glab-cli-config";
- path = "${configHome}/glab-cli/config.yml";
+ path = "${config.dirs.config}/glab-cli/config.yml";
owner = localUsername;
};
gh-hosts = {
file = "${inputs.self}/secrets/gh-hosts";
- path = "${configHome}/gh/hosts.yml";
+ path = "${config.dirs.config}/gh/hosts.yml";
owner = localUsername;
};
hut = {
file = "${inputs.self}/secrets/hut";
- path = "${configHome}/hut/config";
+ path = "${config.dirs.config}/hut/config";
owner = localUsername;
};
};