summaryrefslogtreecommitdiff
path: root/modules/common/htop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/htop.nix')
-rw-r--r--modules/common/htop.nix15
1 files changed, 6 insertions, 9 deletions
diff --git a/modules/common/htop.nix b/modules/common/htop.nix
index bf3f1e4..647abf7 100644
--- a/modules/common/htop.nix
+++ b/modules/common/htop.nix
@@ -1,13 +1,10 @@
-{
- config,
- lib,
- ...
-}:
-with lib; let
+{ config, lib, ... }:
+with lib;
+let
cfg = config.nixfiles.modules.htop;
-in {
- options.nixfiles.modules.htop.enable =
- mkEnableOption "htop";
+in
+{
+ options.nixfiles.modules.htop.enable = mkEnableOption "htop";
config = mkIf cfg.enable {
hm.programs.htop = {