about summary refs log tree commit diff
path: root/modules/common/neovim/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/common/neovim/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/modules/common/neovim/default.nix b/modules/common/neovim/default.nix
new file mode 100644
index 0000000..1e5f103
--- /dev/null
+++ b/modules/common/neovim/default.nix
@@ -0,0 +1,27 @@
+{
+  config,
+  inputs,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.neovim;
+in {
+  options.nixfiles.modules.neovim.enable = mkEnableOption "NeoVim";
+
+  config = mkIf cfg.enable {
+    hm = {
+      imports = [inputs.nixvim.homeManagerModules.nixvim];
+
+      programs.nixvim = {
+        enable = true;
+
+        plugins = {
+          lsp.enable = true;
+          nix.enable = true;
+          surround.enable = true;
+        };
+      };
+    };
+  };
+}

Consider giving Nix/NixOS a try! <3