summaryrefslogtreecommitdiff
path: root/modules/common/networking.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/networking.nix')
-rw-r--r--modules/common/networking.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/modules/common/networking.nix b/modules/common/networking.nix
index e891e58..2867825 100644
--- a/modules/common/networking.nix
+++ b/modules/common/networking.nix
@@ -28,11 +28,14 @@ in
# Remove default hostname mappings. This is required at least by the
# current implementation of the monitoring module.
hosts = {
- "127.0.0.1" = mkForce [ ];
+ "127.0.0.2" = mkForce [ ];
"::1" = mkForce [ ];
};
- nameservers = mkDefault dns.const.quad9.default;
+ nameservers = with my.configurations.manwe.wireguard; [
+ ipv4.address
+ ipv6.address
+ ];
useDHCP = false;