about summary refs log tree commit diff
path: root/modules/common/profiles/dev/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/profiles/dev/default.nix')
-rw-r--r--modules/common/profiles/dev/default.nix84
1 files changed, 0 insertions, 84 deletions
diff --git a/modules/common/profiles/dev/default.nix b/modules/common/profiles/dev/default.nix
deleted file mode 100644
index 6ac1fe6..0000000
--- a/modules/common/profiles/dev/default.nix
+++ /dev/null
@@ -1,84 +0,0 @@
-{
-  config,
-  lib,
-  pkgs,
-  ...
-}:
-with lib;
-let
-  cfg = config.nixfiles.modules.profiles.dev;
-in
-{
-  imports = [
-    ./containers.nix
-    ./hidden.nix
-    ./sql.nix
-  ];
-
-  options.nixfiles.modules.profiles.dev.enable = mkEnableOption "Catch-all profile for stuff related to software development and etc.";
-
-  config = mkIf cfg.enable {
-    nixfiles.modules = {
-      bat.enable = true;
-      curl.enable = true;
-      direnv.enable = true;
-      editorconfig.enable = true;
-      git.client.enable = true;
-      gnupg.enable = true;
-      nmap.enable = true;
-      wget.enable = true;
-    };
-
-    hm = {
-      home = {
-        sessionVariables = rec {
-          CABAL_DIR = "${config.dirs.data}/cabal";
-          CABAL_CONFIG = pkgs.writeText "cabal-config" ''
-            repository hackage.haskell.org
-              url: https://hackage.haskell.org/
-              secure: True
-
-            jobs: $ncpus
-
-            remote-repo-cache: ${CABAL_DIR}/packages
-
-            world-file: ${CABAL_DIR}/world
-
-            logs-dir: ${CABAL_DIR}/logs
-            build-summary: ${CABAL_DIR}/logs/build.log
-
-            installdir: ${CABAL_DIR}/bin
-            extra-prog-path: ${CABAL_DIR}/bin
-          '';
-          STACK_ROOT = "${config.dirs.data}/stack";
-
-          RUSTUP_HOME = "${config.dirs.data}/rustup";
-          CARGO_HOME = "${config.dirs.data}/cargo";
-
-          GOPATH = "${config.dirs.data}/go";
-          GORE_HOME = "${config.dirs.data}/gore";
-
-          PYTHONSTARTUP = ./pystartup.py;
-        };
-
-        packages = with pkgs; [
-          age
-          htmlq
-          httpie
-          hydra-check
-          jq
-          logcli
-          nix-update
-          nixpkgs-review
-          sops
-          yq
-        ];
-      };
-
-      xdg.configFile = {
-        "gdb/gdbinit".source = ./gdbinit;
-        "ghc/ghci.conf".source = ./ghci.conf;
-      };
-    };
-  };
-}

Consider giving Nix/NixOS a try! <3