summaryrefslogtreecommitdiff
path: root/modules/common/profiles/email.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/profiles/email.nix')
-rw-r--r--modules/common/profiles/email.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/modules/common/profiles/email.nix b/modules/common/profiles/email.nix
index 9cc12d7..744d656 100644
--- a/modules/common/profiles/email.nix
+++ b/modules/common/profiles/email.nix
@@ -46,10 +46,16 @@ in {
assert (builtins.isInt line);
concatStringsSep " " (
[
- "${config.hm.programs.password-store.package}/bin/pass show ${path}"
+ "${config.hm.programs.password-store.package}/bin/pass"
+ "show"
+ path
+ ]
+ ++ optionals (line > 0) [
+ "|"
+ "${pkgs.gnused}/bin/sed"
+ "-e"
+ "'${toString line}!d'"
]
- ++ optional (line > 0)
- "| ${pkgs.gnused}/bin/sed -e '${toString line}!d'"
);
in rec {
shire = mkAccount rec {