summaryrefslogtreecommitdiff
path: root/modules/common/profiles/email.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/profiles/email.nix')
-rw-r--r--modules/common/profiles/email.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/modules/common/profiles/email.nix b/modules/common/profiles/email.nix
index 19eaee5..3c809af 100644
--- a/modules/common/profiles/email.nix
+++ b/modules/common/profiles/email.nix
@@ -6,9 +6,9 @@
...
}:
with lib; let
- cfg = config.nixfiles.modules.profiles.email.default;
+ cfg = config.nixfiles.modules.profiles.email;
in {
- options.nixfiles.modules.profiles.email.default.enable =
+ options.nixfiles.modules.profiles.email.enable =
mkEnableOption "Local Email management" // {default = this.isHeadful;};
config = mkIf cfg.enable {
@@ -46,13 +46,13 @@ in {
assert (builtins.isInt line);
concatStringsSep " " (
[
- "${config.hm.programs.password-store.package}/bin/pass"
+ (getExe config.hm.programs.password-store.package)
"show"
path
]
++ optionals (line > 0) [
"|"
- "${pkgs.gnused}/bin/sed"
+ (getExe pkgs.gnused)
"-e"
"'${toString line}!d'"
]