summaryrefslogtreecommitdiff
path: root/modules/common/profiles/headful.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/profiles/headful.nix')
-rw-r--r--modules/common/profiles/headful.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/modules/common/profiles/headful.nix b/modules/common/profiles/headful.nix
index 1578ccc..cd29225 100644
--- a/modules/common/profiles/headful.nix
+++ b/modules/common/profiles/headful.nix
@@ -5,11 +5,14 @@
this,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.profiles.headful;
-in {
- options.nixfiles.modules.profiles.headful.enable =
- mkEnableOption "headful profile" // {default = this.isHeadful;};
+in
+{
+ options.nixfiles.modules.profiles.headful.enable = mkEnableOption "headful profile" // {
+ default = this.isHeadful;
+ };
config = mkIf cfg.enable {
nixfiles.modules = {