about summary refs log tree commit diff
path: root/modules/common/profiles/headless.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/common/profiles/headless.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/modules/common/profiles/headless.nix b/modules/common/profiles/headless.nix
index cc7c326..1f8096c 100644
--- a/modules/common/profiles/headless.nix
+++ b/modules/common/profiles/headless.nix
@@ -5,19 +5,21 @@
   this,
   ...
 }:
-with lib; let
+with lib;
+let
   cfg = config.nixfiles.modules.profiles.headless;
-in {
-  options.nixfiles.modules.profiles.headless.enable =
-    mkEnableOption "headless profile" // {default = this.isHeadless;};
+in
+{
+  options.nixfiles.modules.profiles.headless.enable = mkEnableOption "headless profile" // {
+    default = this.isHeadless;
+  };
 
   config = mkIf cfg.enable {
     hm.home.file = {
       ".hushlogin".text = "";
-      ".bash_history".source =
-        config.hm.lib.file.mkOutOfStoreSymlink "/dev/null";
+      ".bash_history".source = config.hm.lib.file.mkOutOfStoreSymlink "/dev/null";
     };
 
-    environment.systemPackages = with pkgs; [alacritty.terminfo];
+    environment.systemPackages = with pkgs; [ alacritty.terminfo ];
   };
 }

Consider giving Nix/NixOS a try! <3