about summary refs log tree commit diff
path: root/modules/common/secrets.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/common/secrets.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/modules/common/secrets.nix b/modules/common/secrets.nix
index 77dee44..2b8082e 100644
--- a/modules/common/secrets.nix
+++ b/modules/common/secrets.nix
@@ -6,11 +6,10 @@
   this,
   ...
 }:
-with lib;
 {
   imports = [
     inputs.agenix.nixosModules.default
-    (mkAliasOptionModule
+    (lib.mkAliasOptionModule
       [ "secrets" ]
       [
         "age"
@@ -22,9 +21,11 @@ with lib;
   config = {
     age.identityPaths =
       if this.isHeadful then
-        [ "${config.my.home}/.ssh/id_${my.ssh.type}" ]
+        [ "${config.my.home}/.ssh/id_${lib.my.ssh.type}" ]
       else
-        map (attr: attr.path) (filter (attr: attr.type == my.ssh.type) config.services.openssh.hostKeys);
+        config.services.openssh.hostKeys
+        |> lib.filter (attr: attr.type == lib.my.ssh.type)
+        |> map (attr: attr.path);
 
     environment.systemPackages = with pkgs; [
       age

Consider giving Nix/NixOS a try! <3