about summary refs log tree commit diff
path: root/modules/common/subversion.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/common/subversion.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/modules/common/subversion.nix b/modules/common/subversion.nix
index 2bd5e42..9398592 100644
--- a/modules/common/subversion.nix
+++ b/modules/common/subversion.nix
@@ -4,9 +4,11 @@
   pkgs,
   ...
 }:
-with lib; let
+with lib;
+let
   cfg = config.nixfiles.modules.subversion;
-in {
+in
+{
   options.nixfiles.modules.subversion.enable = mkEnableOption "Subversion";
 
   config = mkIf cfg.enable {
@@ -14,7 +16,7 @@ in {
 
     hm.home = {
       file = {
-        ".subversion/config".text = generators.toINI {} {
+        ".subversion/config".text = generators.toINI { } {
           auth = {
             password-stores = "gpg-agent";
             ssl-client-cert-file-prompt = "no";
@@ -26,8 +28,9 @@ in {
             diff-cmd = getExe pkgs.colordiff;
           };
           miscellany = {
-            global-ignores = with config.hm.programs.git;
-              optionalString (ignores != []) (concatStringsSep " " ignores);
+            global-ignores =
+              with config.hm.programs.git;
+              optionalString (ignores != [ ]) (concatStringsSep " " ignores);
             diff-ignore-content-type = "no";
           };
           working-copy = {
@@ -37,7 +40,7 @@ in {
           };
         };
 
-        ".subversion/servers".text = generators.toINI {} {
+        ".subversion/servers".text = generators.toINI { } {
           global = {
             store-auth-creds = "yes";
             store-passwords = "yes";
@@ -46,7 +49,7 @@ in {
         };
       };
 
-      packages = [(pkgs.subversionClient.override {saslSupport = true;})];
+      packages = [ (pkgs.subversionClient.override { saslSupport = true; }) ];
     };
   };
 }

Consider giving Nix/NixOS a try! <3