about summary refs log tree commit diff
path: root/modules/common/wget.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/wget.nix')
-rw-r--r--modules/common/wget.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/modules/common/wget.nix b/modules/common/wget.nix
deleted file mode 100644
index 0e8ee64..0000000
--- a/modules/common/wget.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-{
-  config,
-  lib,
-  pkgs,
-  ...
-}:
-with lib;
-let
-  cfg = config.nixfiles.modules.wget;
-in
-{
-  options.nixfiles.modules.wget.enable = mkEnableOption "wget";
-
-  config = mkIf cfg.enable {
-    hm = {
-      programs.bash.shellAliases.wget = "wget --hsts-file=/tmp/wget-hsts";
-
-      home.sessionVariables.WGETRC = pkgs.writeText "wgetrc" ''
-        adjust_extension = on
-        dirstruct = off
-        follow_ftp = on
-        passive_ftp = off
-        progress = bar
-        quota = inf
-        reclevel = 5
-        recursive = off
-        robots = off
-        timestamping = off
-        tries = 5
-        wait = 0
-        waitretry = 10
-      '';
-    };
-
-    environment.systemPackages = with pkgs; [ wget ];
-  };
-}

Consider giving Nix/NixOS a try! <3