about summary refs log tree commit diff
path: root/modules/common/xdg.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/common/xdg.nix23
1 files changed, 13 insertions, 10 deletions
diff --git a/modules/common/xdg.nix b/modules/common/xdg.nix
index e91d2c5..805afe1 100644
--- a/modules/common/xdg.nix
+++ b/modules/common/xdg.nix
@@ -93,21 +93,24 @@ in
     };
 
     hm.xdg = lib.mkMerge [
-      (with cfg; {
+      {
         enable = true;
 
-        inherit cacheHome;
-        inherit configHome;
-        inherit dataHome;
-        inherit stateHome;
-        inherit userDirs;
-      })
+        inherit (cfg)
+          cacheHome
+          configHome
+          dataHome
+          stateHome
+          userDirs
+          ;
+      }
       (lib.mkIf this.isHeadful {
         mimeApps = {
           enable = true;
-          defaultApplications = lib.mkMerge (
-            lib.mapAttrsToList (n: v: lib.genAttrs v (_: [ "${n}.desktop" ])) cfg.defaultApplications
-          );
+          defaultApplications =
+            cfg.defaultApplications
+            |> lib.mapAttrsToList (n: v: lib.genAttrs v (_: [ "${n}.desktop" ]))
+            |> lib.mkMerge;
         };
       })
     ];

Consider giving Nix/NixOS a try! <3