about summary refs log tree commit diff
path: root/modules/common/zathura.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/common/zathura.nix125
1 files changed, 44 insertions, 81 deletions
diff --git a/modules/common/zathura.nix b/modules/common/zathura.nix
index f78a9e9..b13d2a6 100644
--- a/modules/common/zathura.nix
+++ b/modules/common/zathura.nix
@@ -10,111 +10,74 @@ in {
     mkEnableOption "Zathura PDF reader";
 
   config = mkIf cfg.enable {
-    hm.programs.zathura = with config.nixfiles.modules; {
+    hm.programs.zathura = {
       enable = true;
 
-      options =
-        (with config.colourScheme; {
-          default-fg = white;
-          default-bg = black;
+      options = {
+        recolor = true;
+        recolor-keephue = false;
+        recolor-reverse-video = false;
 
-          statusbar-fg = black;
-          statusbar-bg = white;
+        highlight-transparency = "0.3";
 
-          inputbar-fg = black;
-          inputbar-bg = brightGreen;
+        n-completion-items = 10;
 
-          notification-fg = black;
-          notification-bg = brightBlue;
+        guioptions = "";
 
-          notification-warning-fg = black;
-          notification-warning-bg = brightYellow;
+        statusbar-basename = true;
+        statusbar-home-tilde = true;
 
-          notification-error-fg = black;
-          notification-error-bg = brightRed;
+        statusbar-h-padding = 0;
+        statusbar-v-padding = 0;
 
-          highlight-color = brightYellow;
-          highlight-active-color = yellow;
+        window-height = 800;
+        window-width = 600;
 
-          completion-fg = brightWhite;
-          completion-bg = brightBlack;
+        window-icon = "";
 
-          completion-highlight-fg = black;
-          completion-highlight-bg = brightRed;
+        abort-clear-search = true;
 
-          completion-group-fg = black;
-          completion-group-bg = brightRed;
+        incremental-search = true;
 
-          recolor-darkcolor = black;
-          recolor-lightcolor = white;
-        })
-        // {
-          recolor = true;
-          recolor-keephue = false;
-          recolor-reverse-video = false;
+        adjust-open = "best-fit";
 
-          highlight-transparency = "0.3";
+        advance-pages-per-row = false;
 
-          font = config.fontScheme.monospaceFont.family;
+        database = "sqlite";
 
-          n-completion-items = 10;
+        dbus-service = false;
 
-          guioptions = "";
+        page-padding = 0;
 
-          statusbar-basename = true;
-          statusbar-home-tilde = true;
+        pages-per-row = 1;
 
-          statusbar-h-padding = 0;
-          statusbar-v-padding = 0;
+        render-loading = false;
 
-          window-height = 800;
-          window-width = 600;
+        show-directories = true;
+        show-hidden = true;
+        show-recent = 10;
 
-          window-icon = "";
+        link-zoom = true;
+        link-hadjust = true;
 
-          abort-clear-search = true;
+        window-title-basename = true;
+        window-title-home-tilde = true;
+        window-title-page = true;
 
-          incremental-search = true;
+        zoom-center = false;
+        zoom-max = 1000;
+        zoom-min = 10;
+        zoom-step = 10;
 
-          adjust-open = "best-fit";
+        scroll-hstep = -1;
+        scroll-step = 40;
+        scroll-full-overlap = 0;
+        scroll-wrap = true;
+        scroll-page-aware = false;
 
-          advance-pages-per-row = false;
-
-          database = "sqlite";
-
-          dbus-service = false;
-
-          page-padding = 0;
-
-          pages-per-row = 1;
-
-          render-loading = false;
-
-          show-directories = true;
-          show-hidden = true;
-          show-recent = 10;
-
-          link-zoom = true;
-          link-hadjust = true;
-
-          window-title-basename = true;
-          window-title-home-tilde = true;
-          window-title-page = true;
-
-          zoom-center = false;
-          zoom-max = 1000;
-          zoom-min = 10;
-          zoom-step = 10;
-
-          scroll-hstep = -1;
-          scroll-step = 40;
-          scroll-full-overlap = 0;
-          scroll-wrap = true;
-          scroll-page-aware = false;
-
-          selection-clipboard = "clipboard";
-          selection-notification = false;
-        };
+        selection-clipboard = "clipboard";
+        selection-notification = false;
+      };
     };
   };
 }

Consider giving Nix/NixOS a try! <3