summaryrefslogtreecommitdiff
path: root/modules/common/zathura.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common/zathura.nix')
-rw-r--r--modules/common/zathura.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/modules/common/zathura.nix b/modules/common/zathura.nix
index f78a9e9..408f218 100644
--- a/modules/common/zathura.nix
+++ b/modules/common/zathura.nix
@@ -10,6 +10,11 @@ in {
mkEnableOption "Zathura PDF reader";
config = mkIf cfg.enable {
+ nixfiles.modules.common.xdg.defaultApplications."org.pwmt.zathura" = [
+ "application/pdf"
+ "application/epub+zip"
+ ];
+
hm.programs.zathura = with config.nixfiles.modules; {
enable = true;