about summary refs log tree commit diff
path: root/modules/curl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/curl.nix')
-rw-r--r--modules/curl.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/modules/curl.nix b/modules/curl.nix
index 3c318fc..aa6ff27 100644
--- a/modules/curl.nix
+++ b/modules/curl.nix
@@ -4,14 +4,13 @@
   pkgs,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.curl;
 in
 {
-  options.nixfiles.modules.curl.enable = mkEnableOption "cURL";
+  options.nixfiles.modules.curl.enable = lib.mkEnableOption "cURL";
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     hm.xdg.configFile.".curlrc".text = ''
       connect-timeout = 60
       progress-bar
@@ -31,7 +30,7 @@ in
             form="$form-"
         fi
 
-        ${getExe curl} --form "$form" "$url"
+        ${lib.getExe curl} --form "$form" "$url"
       '')
     ];
   };

Consider giving Nix/NixOS a try! <3