summaryrefslogtreecommitdiff
path: root/modules/darwin/common/networking.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/darwin/common/networking.nix')
-rw-r--r--modules/darwin/common/networking.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/darwin/common/networking.nix b/modules/darwin/common/networking.nix
new file mode 100644
index 0000000..6c503bc
--- /dev/null
+++ b/modules/darwin/common/networking.nix
@@ -0,0 +1,10 @@
+{
+ this,
+ localHostname ? this.hostname,
+ ...
+}: {
+ networking = {
+ computerName = localHostname;
+ hostName = localHostname;
+ };
+}