summaryrefslogtreecommitdiff
path: root/modules/darwin/common/users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/darwin/common/users.nix')
-rw-r--r--modules/darwin/common/users.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/darwin/common/users.nix b/modules/darwin/common/users.nix
new file mode 100644
index 0000000..957e50c
--- /dev/null
+++ b/modules/darwin/common/users.nix
@@ -0,0 +1,11 @@
+{
+ lib,
+ localUsername ? lib.my.username,
+ ...
+}:
+with lib; {
+ # The only MacOS machine I'm currently using has a pre-configured domain user
+ # account that I have to login as. I may accidentally break something if I
+ # change options here so this section is left practically untouched.
+ users.users.${localUsername}.home = "/Users/${localUsername}";
+}