about summary refs log tree commit diff
path: root/modules/darwin/gnupg.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/darwin/gnupg.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/darwin/gnupg.nix b/modules/darwin/gnupg.nix
new file mode 100644
index 0000000..073d3b1
--- /dev/null
+++ b/modules/darwin/gnupg.nix
@@ -0,0 +1,15 @@
+{
+  config,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.gnupg;
+in {
+  config = mkIf cfg.enable {
+    programs.gnupg.agent = {
+      enable = true;
+      enableSSHSupport = true;
+    };
+  };
+}

Consider giving Nix/NixOS a try! <3