about summary refs log tree commit diff
path: root/modules/darwin/profiles/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/darwin/profiles/default.nix94
1 files changed, 0 insertions, 94 deletions
diff --git a/modules/darwin/profiles/default.nix b/modules/darwin/profiles/default.nix
deleted file mode 100644
index 9a3353f..0000000
--- a/modules/darwin/profiles/default.nix
+++ /dev/null
@@ -1,94 +0,0 @@
-{
-  config,
-  lib,
-  pkgs,
-  ...
-}:
-with lib;
-let
-  cfg = config.nixfiles.modules.profiles.default;
-in
-{
-  imports = [ ./headful.nix ];
-
-  config = mkIf cfg.enable {
-    hm.home.packages = with pkgs; [ m-cli ];
-
-    system = {
-      defaults = {
-        CustomUserPreferences = { };
-
-        ActivityMonitor = { };
-
-        NSGlobalDomain = {
-          AppleEnableMouseSwipeNavigateWithScrolls = true;
-          AppleEnableSwipeNavigateWithScrolls = true;
-
-          AppleInterfaceStyle = null;
-
-          AppleShowAllExtensions = true;
-          AppleShowAllFiles = true;
-
-          InitialKeyRepeat = 15;
-          KeyRepeat = 2;
-
-          NSAutomaticCapitalizationEnabled = false;
-          NSAutomaticDashSubstitutionEnabled = false;
-          NSAutomaticPeriodSubstitutionEnabled = false;
-          NSAutomaticQuoteSubstitutionEnabled = false;
-          NSAutomaticSpellingCorrectionEnabled = false;
-
-          # Make function keys to work as they should.
-          "com.apple.keyboard.fnState" = true;
-
-          # Disable the absolutely retarded "natural" scrolling.
-          "com.apple.swipescrolldirection" = false;
-        };
-
-        dock = {
-          orientation = "bottom";
-          tilesize = 18;
-
-          # Don't change these options because this will disallow rearranging
-          # shortcuts.
-          show-recents = true;
-          static-only = false;
-
-          # Disable hot corners.
-          wvous-bl-corner = 1;
-          wvous-br-corner = 1;
-          wvous-tl-corner = 1;
-          wvous-tr-corner = 1;
-        };
-
-        finder = {
-          AppleShowAllExtensions = true;
-          AppleShowAllFiles = true;
-
-          CreateDesktop = true;
-
-          FXDefaultSearchScope = "SCcf";
-          FXEnableExtensionChangeWarning = false;
-          FXPreferredViewStyle = "clmv";
-
-          ShowStatusBar = false;
-          ShowPathbar = true;
-          _FXShowPosixPathInTitle = true;
-        };
-
-        trackpad = {
-          Clicking = true;
-          Dragging = false;
-        };
-      };
-
-      keyboard = {
-        enableKeyMapping = true;
-        nonUS.remapTilde = true;
-        remapCapsLockToControl = false;
-        remapCapsLockToEscape = true;
-        swapLeftCommandAndLeftAlt = false;
-      };
-    };
-  };
-}

Consider giving Nix/NixOS a try! <3