about summary refs log tree commit diff
path: root/modules/darwin/profiles/headful.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/darwin/profiles/headful.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/darwin/profiles/headful.nix b/modules/darwin/profiles/headful.nix
new file mode 100644
index 0000000..44695f6
--- /dev/null
+++ b/modules/darwin/profiles/headful.nix
@@ -0,0 +1,19 @@
+{
+  config,
+  lib,
+  pkgs,
+  this,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.profiles.headful;
+in {
+  config = mkIf cfg.enable {
+    nixfiles.modules.homebrew.enable = true;
+
+    homebrew.casks = [
+      {name = "firefox";}
+      {name = "telegram-desktop";}
+    ];
+  };
+}

Consider giving Nix/NixOS a try! <3