about summary refs log tree commit diff
path: root/modules/firefox/addons.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/firefox/addons.nix315
1 files changed, 315 insertions, 0 deletions
diff --git a/modules/firefox/addons.nix b/modules/firefox/addons.nix
new file mode 100644
index 0000000..54e67ee
--- /dev/null
+++ b/modules/firefox/addons.nix
@@ -0,0 +1,315 @@
+{ buildFirefoxXpiAddon, lib }:
+{
+  "bitwarden" = buildFirefoxXpiAddon {
+    pname = "bitwarden";
+    version = "2024.4.1";
+    addonId = "{446900e4-71c2-419f-a6a7-df9c091e268b}";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4263752/bitwarden_password_manager-2024.4.1.xpi";
+    sha256 = "1ba1e66cb9a4ee3bf80a81fc31348b04162385455d2b02f9902473e3931d9693";
+    meta = with lib; {
+      homepage = "https://bitwarden.com";
+      description = "At home, at work, or on the go, Bitwarden easily secures all your passwords, passkeys, and sensitive information.";
+      license = licenses.gpl3;
+      mozPermissions = [
+        "<all_urls>"
+        "*://*/*"
+        "tabs"
+        "contextMenus"
+        "storage"
+        "unlimitedStorage"
+        "clipboardRead"
+        "clipboardWrite"
+        "idle"
+        "webRequest"
+        "webRequestBlocking"
+        "file:///*"
+        "https://*/*"
+        "https://lastpass.com/export.php"
+      ];
+      platforms = platforms.all;
+    };
+  };
+  "consent-o-matic" = buildFirefoxXpiAddon {
+    pname = "consent-o-matic";
+    version = "1.0.13";
+    addonId = "gdpr@cavi.au.dk";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4246350/consent_o_matic-1.0.13.xpi";
+    sha256 = "ee577eaedebd9fef65f77218b86c59972818442c9af551d551a7015a4a246e9a";
+    meta = with lib; {
+      homepage = "https://consentomatic.au.dk/";
+      description = "Automatic handling of GDPR consent forms";
+      license = licenses.mit;
+      mozPermissions = [
+        "activeTab"
+        "tabs"
+        "storage"
+        "<all_urls>"
+      ];
+      platforms = platforms.all;
+    };
+  };
+  "darkreader" = buildFirefoxXpiAddon {
+    pname = "darkreader";
+    version = "4.9.83";
+    addonId = "addon@darkreader.org";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4262984/darkreader-4.9.83.xpi";
+    sha256 = "a43cca2449de202d17040b0d91b2fb3ed4dd58ac81ec5d3fde4c9940d326c822";
+    meta = with lib; {
+      homepage = "https://darkreader.org/";
+      description = "Dark mode for every website. Take care of your eyes, use dark theme for night and daily browsing.";
+      license = licenses.mit;
+      mozPermissions = [
+        "alarms"
+        "contextMenus"
+        "storage"
+        "tabs"
+        "theme"
+        "<all_urls>"
+      ];
+      platforms = platforms.all;
+    };
+  };
+  "furiganaize" = buildFirefoxXpiAddon {
+    pname = "furiganaize";
+    version = "0.7.2";
+    addonId = "{a2503cd4-4083-4c2f-bef2-37767a569867}";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4032306/furiganaize-0.7.2.xpi";
+    sha256 = "7545bc418f2afbc576b0e762f2b2fa0545d5d94f3f80737e5356d087a5951c0b";
+    meta = with lib; {
+      homepage = "https://github.com/kuanyui/Furiganaize";
+      description = "Auto insert furigana (振り仮名) on Japanese kanji.";
+      license = licenses.mit;
+      mozPermissions = [
+        "http://*/*"
+        "https://*/*"
+        "file://*/*"
+        "<all_urls>"
+        "activeTab"
+        "tabs"
+        "storage"
+      ];
+      platforms = platforms.all;
+    };
+  };
+  "ipfs-companion" = buildFirefoxXpiAddon {
+    pname = "ipfs-companion";
+    version = "3.1.0";
+    addonId = "ipfs-firefox-addon@lidel.org";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4172699/ipfs_companion-3.1.0.xpi";
+    sha256 = "784f6d1e0497d86f1e42cfe7de8548b5cc28fabe80e50771d90f59ddf1b9d3c1";
+    meta = with lib; {
+      homepage = "https://github.com/ipfs/ipfs-companion";
+      description = "Harness the power of IPFS in your browser";
+      license = licenses.cc0;
+      mozPermissions = [
+        "idle"
+        "tabs"
+        "notifications"
+        "proxy"
+        "storage"
+        "unlimitedStorage"
+        "contextMenus"
+        "clipboardWrite"
+        "webNavigation"
+        "webRequest"
+        "webRequestBlocking"
+      ];
+      platforms = platforms.all;
+    };
+  };
+  "languagetool" = buildFirefoxXpiAddon {
+    pname = "languagetool";
+    version = "8.6.0";
+    addonId = "languagetool-webextension@languagetool.org";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4249956/languagetool-8.6.0.xpi";
+    sha256 = "d9db9aac9fdd53eb39179c153161762cd9e9eb1f6d7da8e8b8a32238b4847094";
+    meta = with lib; {
+      homepage = "https://languagetool.org";
+      description = "With this extension you can check text with the free style and grammar checker LanguageTool. It finds many errors that a simple spell checker cannot detect, like mixing up there/their, a/an, or repeating a word.";
+      mozPermissions = [
+        "activeTab"
+        "storage"
+        "contextMenus"
+        "alarms"
+        "http://*/*"
+        "https://*/*"
+        "file:///*"
+        "*://docs.google.com/document/*"
+        "*://languagetool.org/*"
+      ];
+      platforms = platforms.all;
+    };
+  };
+  "no-pdf-download" = buildFirefoxXpiAddon {
+    pname = "no-pdf-download";
+    version = "1.0.6";
+    addonId = "{b9b25e4a-bdf4-4270-868c-3f619eaf437d}";
+    url = "https://addons.mozilla.org/firefox/downloads/file/3020560/no_pdf_download-1.0.6.xpi";
+    sha256 = "fa27b6729178a23ccf2eee07cd7650d841fc6040f2e5adfb919931b671ed79e6";
+    meta = with lib; {
+      homepage = "https://github.com/MorbZ/no-pdf-download";
+      description = "Opens all PDF files directly in the browser.";
+      license = licenses.mit;
+      mozPermissions = [
+        "webRequest"
+        "webRequestBlocking"
+        "<all_urls>"
+      ];
+      platforms = platforms.all;
+    };
+  };
+  "redirector" = buildFirefoxXpiAddon {
+    pname = "redirector";
+    version = "3.5.3";
+    addonId = "redirector@einaregilsson.com";
+    url = "https://addons.mozilla.org/firefox/downloads/file/3535009/redirector-3.5.3.xpi";
+    sha256 = "eddbd3d5944e748d0bd6ecb6d9e9cf0e0c02dced6f42db21aab64190e71c0f71";
+    meta = with lib; {
+      homepage = "http://einaregilsson.com/redirector/";
+      description = "Automatically redirects to user-defined urls on certain pages";
+      license = licenses.mit;
+      mozPermissions = [
+        "webRequest"
+        "webRequestBlocking"
+        "webNavigation"
+        "storage"
+        "tabs"
+        "http://*/*"
+        "https://*/*"
+        "notifications"
+      ];
+      platforms = platforms.all;
+    };
+  };
+  "rikaichamp" = buildFirefoxXpiAddon {
+    pname = "rikaichamp";
+    version = "1.18.0";
+    addonId = "{59812185-ea92-4cca-8ab7-cfcacee81281}";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4241410/10ten_ja_reader-1.18.0.xpi";
+    sha256 = "5433bcfec5a327bf1fa198b3f0645a9cdcdc44232465ad940fa8a5858b6996f8";
+    meta = with lib; {
+      homepage = "https://github.com/birchill/10ten-ja-reader/";
+      description = "Quickly translate Japanese by hovering over words. Formerly released as Rikaichamp.";
+      license = licenses.gpl3;
+      mozPermissions = [
+        "alarms"
+        "clipboardWrite"
+        "contextMenus"
+        "storage"
+        "unlimitedStorage"
+        "http://*/*"
+        "https://*/*"
+        "file:///*"
+        "https://docs.google.com/*"
+      ];
+      platforms = platforms.all;
+    };
+  };
+  "skip-redirect" = buildFirefoxXpiAddon {
+    pname = "skip-redirect";
+    version = "2.3.6";
+    addonId = "skipredirect@sblask";
+    url = "https://addons.mozilla.org/firefox/downloads/file/3920533/skip_redirect-2.3.6.xpi";
+    sha256 = "dbe8950245c1f475c5c1c6daab89c79b83ba4680621c91e80f15be7b09b618ae";
+    meta = with lib; {
+      description = "Some web pages use intermediary pages before redirecting to a final page. This add-on tries to extract the final url from the intermediary url and goes there straight away if successful.";
+      license = licenses.mit;
+      mozPermissions = [
+        "<all_urls>"
+        "clipboardWrite"
+        "contextMenus"
+        "notifications"
+        "storage"
+        "webRequest"
+        "webRequestBlocking"
+      ];
+      platforms = platforms.all;
+    };
+  };
+  "ublock-origin" = buildFirefoxXpiAddon {
+    pname = "ublock-origin";
+    version = "1.57.2";
+    addonId = "uBlock0@raymondhill.net";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4261710/ublock_origin-1.57.2.xpi";
+    sha256 = "9928e79a52cecf7cfa231fdb0699c7d7a427660d94eb10d711ed5a2f10d2eb89";
+    meta = with lib; {
+      homepage = "https://github.com/gorhill/uBlock#ublock-origin";
+      description = "Finally, an efficient wide-spectrum content blocker. Easy on CPU and memory.";
+      license = licenses.gpl3;
+      mozPermissions = [
+        "alarms"
+        "dns"
+        "menus"
+        "privacy"
+        "storage"
+        "tabs"
+        "unlimitedStorage"
+        "webNavigation"
+        "webRequest"
+        "webRequestBlocking"
+        "<all_urls>"
+        "http://*/*"
+        "https://*/*"
+        "file://*/*"
+        "https://easylist.to/*"
+        "https://*.fanboy.co.nz/*"
+        "https://filterlists.com/*"
+        "https://forums.lanik.us/*"
+        "https://github.com/*"
+        "https://*.github.io/*"
+        "https://*.letsblock.it/*"
+        "https://github.com/uBlockOrigin/*"
+        "https://ublockorigin.github.io/*"
+        "https://*.reddit.com/r/uBlockOrigin/*"
+      ];
+      platforms = platforms.all;
+    };
+  };
+  "user-agent-switcher" = buildFirefoxXpiAddon {
+    pname = "user-agent-switcher";
+    version = "0.5.0";
+    addonId = "{a6c4a591-f1b2-4f03-b3ff-767e5bedf4e7}";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4098688/user_agent_string_switcher-0.5.0.xpi";
+    sha256 = "9dc8da3c8c46d4f04d12fd789c63501fa6a2f502f859b286939a090db63eae33";
+    meta = with lib; {
+      homepage = "http://add0n.com/useragent-switcher.html";
+      description = "Spoof websites trying to gather information about your web navigation—like your browser type and operating system—to deliver distinct content you may not want.";
+      license = licenses.mpl20;
+      mozPermissions = [
+        "storage"
+        "<all_urls>"
+        "webNavigation"
+        "webRequest"
+        "webRequestBlocking"
+        "contextMenus"
+        "*://*/*"
+      ];
+      platforms = platforms.all;
+    };
+  };
+  "violentmonkey" = buildFirefoxXpiAddon {
+    pname = "violentmonkey";
+    version = "2.18.0";
+    addonId = "{aecec67f-0d10-4fa7-b7c7-609a2db280cf}";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4220396/violentmonkey-2.18.0.xpi";
+    sha256 = "4abbeea842b82965379c6011dec6a435dfff0f69c20749118a8ba2f7d14cb0f1";
+    meta = with lib; {
+      homepage = "https://violentmonkey.github.io/";
+      description = "Userscript support for browsers, open source.";
+      license = licenses.mit;
+      mozPermissions = [
+        "tabs"
+        "<all_urls>"
+        "webRequest"
+        "webRequestBlocking"
+        "notifications"
+        "storage"
+        "unlimitedStorage"
+        "clipboardWrite"
+        "contextMenus"
+        "cookies"
+      ];
+      platforms = platforms.all;
+    };
+  };
+}

Consider giving Nix/NixOS a try! <3