about summary refs log tree commit diff
path: root/modules/games/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/games/default.nix26
1 files changed, 12 insertions, 14 deletions
diff --git a/modules/games/default.nix b/modules/games/default.nix
index dea9d3c..4f474b4 100644
--- a/modules/games/default.nix
+++ b/modules/games/default.nix
@@ -8,20 +8,18 @@ in
 
   options.nixfiles.modules.games.enable32BitSupport = mkEnableOption "support for games";
 
-  config = mkIf cfg.enable32BitSupport {
-    services = {
-      jack.alsa.support32Bit = config.services.jack.alsa.enable;
-
-      pipewire.alsa.support32Bit = config.services.pipewire.alsa.enable;
-    };
-
-    hardware = {
-      opengl = mkIf config.hardware.opengl.enable {
-        extraPackages32 = config.hardware.opengl.extraPackages;
-        driSupport32Bit = config.hardware.opengl.driSupport;
+  config = mkMerge [
+    { hardware.graphics.enable = true; }
+    (mkIf cfg.enable32BitSupport {
+      services = {
+        jack.alsa.support32Bit = config.services.jack.alsa.enable;
+        pipewire.alsa.support32Bit = config.services.pipewire.alsa.enable;
       };
 
-      pulseaudio.support32Bit = config.hardware.pulseaudio.enable;
-    };
-  };
+      hardware = {
+        graphics.enable32Bit = true;
+        pulseaudio.support32Bit = config.hardware.pulseaudio.enable;
+      };
+    })
+  ];
 }

Consider giving Nix/NixOS a try! <3