summaryrefslogtreecommitdiff
path: root/modules/games/gamemode.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/games/gamemode.nix')
-rw-r--r--modules/games/gamemode.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/games/gamemode.nix b/modules/games/gamemode.nix
new file mode 100644
index 0000000..eb485f8
--- /dev/null
+++ b/modules/games/gamemode.nix
@@ -0,0 +1,14 @@
+{ config, lib, ... }:
+with lib;
+let
+ cfg = config.nixfiles.modules.games.gamemode;
+in
+{
+ options.nixfiles.modules.games.gamemode.enable = mkEnableOption "Feral GameMode";
+
+ config = mkIf cfg.enable {
+ hm.xdg.configFile."gamemode.ini".text = generators.toINI { } { general.softrealtime = "auto"; };
+
+ programs.gamemode.enable = true;
+ };
+}